wormhole(虫洞)(bellman ford)(判断负权环)

2831.    Wormholes
Time Limit: 1.0 Seconds    Memory Limit: 65536K
Total Runs: 1271    Accepted Runs: 404     Multiple test files



While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises  N (1 ≤  N ≤ 500) fields conveniently numbered 1.. NM (1 ≤  M ≤ 2500) paths, and  W (1 ≤  W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

* Line 1: A single integer,  FF farm descriptions follow.

* Line 1 of each farm: Three space-separated integers respectively: NM, and W

* Lines 2..M + 1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

* Lines M + 2..M + W + 1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

* Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Input Details

Two farm maps. The first has three paths and one wormhole, and the second has two paths and one wormhole.

Output Details

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.


题意是FJ有好几个农场,农场中有不同的虫洞,在不同虫洞之间王往来有N条路,各有自己的cost,而通过虫洞可以回到过去,使时间减少。他想是否可以时空穿越从一个点出发再回到同一个点上。这道题就成了判断个图中是否有负权环,利用bellmamnford,再加上spfa优化,然后要注意这里并不能保证每个点之间都是互相联通的,所以需要以每个未标记vis[]的点为起点再跑一遍。


#include <iostream>
#include<stdio.h>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;

int n,m,w,head[500],nc,dis[500];

struct edge{
    int to,nex,cost;
};
edge e[50005];
int addedge(int a,int b,int c)
{
    e[nc].to=b;
    e[nc].cost=c;
    e[nc].nex=head[a];
    head[a]=nc++;
    return a;
}

bool spfa(int s)
{
    int x,y,l[1000],top,tail,used[520];
    bool mark[520];
    memset(mark,false,sizeof(mark));
    memset(used,0,sizeof(used));
    top=tail=0;
    l[top++]=s;
    used[s]++;
    mark[s]=1;
    dis[s]=0;
    while(tail!=top)
    {
        x=l[tail++];
        mark[x]=0;
        if(tail==999)
            tail=0;
        for(int i=head[x];i!=-1;i=e[i].nex)
        {
            y=e[i].to;
            if(dis[y]>e[i].cost+dis[x])
            {
                dis[y]=e[i].cost+dis[x];
                used[y]++;
                if(used[y]>=n)
                    return false;
                if(!mark[y])
                {
                    mark[y]=1;
                    l[top++]=y;
                    if(top==999)
                        top=0;
                }
            }

        }
    }
    return true;
}

int main()
{
    int num,a,b,c;
    scanf("%d",&num);
    while(num--)
    {
        nc=0;
        scanf("%d%d%d",&n,&m,&w);
        memset(head,-1,sizeof(head));
        memset(dis,inf,sizeof(dis));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            addedge(a,b,c);
            addedge(b,a,c);
        }
        for(int i=0;i<w;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            addedge(a,b,-c);
        }
        int i;
        for(i=1;i<=n;i++)
        {
            if(dis[i]==inf)
                if(!spfa(i))
            {
                i=n+2;
                break;
            }
        }
         if(i==n+1) printf("NO\n");
         else printf("YES\n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在 Android 13 中,SurfaceFlinger 的主线程扫描所有的 Surface 对象的代码主要是由 `SurfaceFlinger::onMessageRefresh` 方法实现的。该方法是主线程的消息处理函数,当主线程收到“刷新”消息时,就会调用该方法。 具体来说,`SurfaceFlinger::onMessageRefresh` 方法的代码路径如下: 1. 遍历 SurfaceFlinger 中的所有 Layer(即 Surface 对象),并检查它们的状态是否发生了改变。这个过程是由主线程中的 `mDrawingState.traverseInZOrder` 方法实现的,该方法会遍历所有的 Layer,并调用每个 Layer 的 `onPreComposition` 方法来检查它们的状态。 2. 如果某个 Layer 的状态发生了改变,就会调用相应的客户端进程,要求其重新提交该 Layer 的缓冲区。这个过程是由 `SurfaceFlinger::postComposition` 方法实现的,该方法会遍历所有的 Layer,并调用每个 Layer 的 `onPostComposition` 方法来通知客户端进程。 3. 如果客户端进程提交了新的缓冲区,就会将这些缓冲区合成到一个帧缓冲区中,并在下一次屏幕刷新时将其发送到显示器。这个过程是由主线程中的 `composeSurfaces` 和 `drawWormhole` 方法实现的,它们会将所有的 Layer 缓冲区合成到一个帧缓冲区中,并在需要时添加(Wormhole)层用于处理透明度。 下面是 `SurfaceFlinger::onMessageRefresh` 方法的伪代码: ```cpp void SurfaceFlinger::onMessageRefresh() { // 遍历所有的 Layer,并检查它们的状态是否发生了改变 mDrawingState.traverseInZOrder([&](Layer* layer) { // 调用每个 Layer 的 onPreComposition 方法来检查它们的状态 layer->onPreComposition(); }); // 如果某个 Layer 的状态发生了改变,就通知客户端进程重新提交缓冲区 postComposition(); // 将所有的 Layer 缓冲区合成到一个帧缓冲区中,并添加层 composeSurfaces(); drawWormhole(); } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值